Uitgave-opmerking / Piwigo 2.9.1

bug fixes (including security)

2.9.1
Download Piwigo2.9.1

Uitgegeven op 15 juni 2017

md5sum

De lijst met belangrijke wijzigingen wordt beschreven in de release-opmerking van Piwigo2.9.0

Fouten hersteld

Bekende problemen

Talen

Uitgelicht toegevoegd

Upgrade

Fouten hersteld

707 / Weergeven

aantal weergaven, verberg decimalen indien minder dan 1k

706 / Security

[veiligheid] identificatie mag enkel redirecten binnen Piwigo

705 / Security

gebruikerslijst backend, controleer input parameter

701 / Tools

De link om een album te synchroniseren verwijst naar de pagina om ./galleries/ te synchroniseren zelfs als het album in een andere folder zit.

699 / Security

Bestandsintegratie in administratie

696 / web API

PIWIGO API - pwg.categories.delete werkt niet naar behoren.

693 / Technical

Batch downloader faalt bij gebruik van pclzip and php 7.1

685 / Photos

batch manager, verwijder foto werkt niet met Safari

683 / Weergeven

disk gebruik, verberg decimalen indien meer dan 100GB

679 / Technical

admin dashboard, heeft trigger nodig voor plugins

674 / Technical

[php7.1] gebruiker edit box, [] operator niet ondersteund voor strings

667 / Security

Bug melding: Cross Site Scripting(XSS) in pagina parameter van admin.php

663 / Technical

SQL fout in rondleiding 2.9

Bekende problemen

710 / Security

input parameter "redirect_decoded" is niet geldig

Talen

Geupdate talen

Catalaans (Català)

Brits Engels (British English)

Esperanto

Baskisch (Euskara)

Fins (suomi)

Frans Canadees (Québecois)

Hongaars (Magyar)

Combodjaans (ភាសាខ្មែរ)

Portugees (Português)

Roemeens (Română)

Slowaaks (Slovensky)

Sloveens (Slovenščina)

Servisch (Српски)

Zweeds (Svenska)

Vietnamees (Tiếng Việt)

Chinees (简体中文)

Hong-Kongs (中文香港)

Upgrade

We raden de automatische upgrade aan. Als je versie 2.2 + gebruikt, zal Piwigo je vóór de upgrade vertellen welke plug-ins mogelijk niet compatibel zijn met Piwigo2.9.

Als je Piwigo2.9.0 gebruikt, kunt je ook het archief 2.9.0_to_2.9.1.zip downloaden dat alle nieuwe en gewijzigde bestanden bevat. Nadat je de bestanden hebt uitgepakt, breng je ze over naar jouw webserver met een FTP-cliënt via de installatie van Piwigo2.9.0. Er is geen database-upgrade vereist.

Als je een oudere versie dan 2.9 gebruikt en de automatische upgrade niet wilt gebruiken, volg dan de handmatige upgrade .