Uitgave-opmerking / Piwigo 2.9.4

bug fixes (including security)

2.9.4
Download Piwigo2.9.4

Uitgegeven op 13 juli 2018

md5sum

De lijst met belangrijke wijzigingen wordt beschreven in de release-opmerking van Piwigo2.9.0

Fouten hersteld

Bekende problemen

Talen

Uitgelicht toegevoegd

Upgrade

Fouten hersteld

894 / Technical

Los syntax-fout op

891 / Security

link naar piwigo.org zou nu in HTTPS moeten staan

890 / Security

http/https gemengde inhoud bij [Beheerder> Foto's> Toevoegen> Toepassingen]

889 / Technical

Oplossing voor Smarty en PHP7.2

888 / Technical

Oplossing voor Cssmin met php7.2 en hoger

887 / Technical

PHP7.2, waarschuwing voor gebruikersbeheerder

877 / Users & Groups

conflict op de website_url kolom met externe gebruikerstabel

872 / Security

CVE-2018-7724

853 / Technical

Piwigo 2.9.3 heeft problemen met de plugin Colored Tags

847 / Security

CVE-2018-5692

844 / Weergeven

Ontbrekende link-tag in /recent_cats breadcrumb

834 / Technical

Eerste werk ter ondersteuning van PHP 7.2

748 / Security

Kan gebruikers niet bekijken - 403-fout in user_list_backend.php

596 / Technical

PHP 7.1 en template.class.php incompatibiliteit

258 / Photos

[albums] Batch-beheer van een sinds-verwijderd album geeft SQL-fout

Bekende problemen

897 / Technical

[2.9.4] onverwachte T_FUNCTION in functions_mysqli.inc.php in regel 403

902 / Users & Groups

[2.9.4] users list no longer paginated or filtered

Talen

Geupdate talen

Deens (Dansk)

Grieks (Ελληνικά)

Esperanto

Estlands (eesti)

Persisch (فارسی)

Fins (suomi)

Frans Canadees (Québecois)

Hebreeuws (עברית)

Hongaars (Magyar)

Japans (日本語)

Litouwens (Lietuvių)

Nederlands

Pools (Polski)

Portugees (Português)

Roemeens (Română)

Turks (Türkçe)

Vietnamees (Tiếng Việt)

Upgrade

We raden de automatische upgrade aan. Als je versie 2.2 + gebruikt, zal Piwigo je vóór de upgrade vertellen welke plug-ins mogelijk niet compatibel zijn met Piwigo2.9.

Als je Piwigo2.9.x gebruikt, kunt je ook het archief 2.9.x_to_2.9.4.zip downloaden dat alle nieuwe en gewijzigde bestanden bevat. Nadat je de bestanden hebt uitgepakt, breng je ze over naar jouw webserver met een FTP-cliënt via de installatie van Piwigo2.9.x. Er is geen database-upgrade vereist.

Als je een oudere versie dan 2.9 gebruikt en de automatische upgrade niet wilt gebruiken, volg dan de handmatige upgrade .